Back to overview
Downtime
API Incident
Apr 23, 2026 at 7:48am UTC
Affected services
Fetch Person - Person (live)
Fetch Company - company (live)
Resolved
Apr 26, 2026 at 5:51pm UTC
Hey, after several days of intense work, our engineering team has managed to stabilize the endpoints that were causing issues. We're still actively monitoring things, so you might occasionally see some residual errors pop up. The team is continuing to track them and push fixes as fast as possible. Thanks so much for your patience!
Affected services
Created
Apr 23, 2026 at 7:48am UTC
We're aware of an ongoing incident impacting API requests. Our team is fully mobilized and working to restore normal service as quickly as possible. Thanks for your patience.
Affected services