Back to overview
Resolved

Degraded performance on Search endpoints (companies & persons)

Sep 9, 2026 at 12:32pm UTC
Affected services
Search API - Person Search
Search API - Company Search

Resolved
Sep 10, 2026 at 7:28am UTC

Search back to normal

Created
Sep 9, 2026 at 12:32pm UTC

We are seeing increased latency on our Search endpoints (companies and persons). Our team is working on a fix and we will update this page as soon as the situation is resolved.